Bank Norwegian - Degraded performance
Incident Report for Tink providers Norway
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Apr 02, 2024 - 12:13 UTC
Investigating
We are currently investigating an issue with Bank Norwegian.
Posted Apr 01, 2024 - 20:29 UTC
This incident affected: Bank Norwegian.