Nordea - Major outage

Incident Report for Tink providers Norway

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Jun 28, 2025 - 19:53 UTC

Investigating

We are currently investigating an issue with Nordea.
Posted Jun 28, 2025 - 19:07 UTC
This incident affected: Nordea.