Nordea Open Banking - Major Outage
Incident Report for Tink providers Norway
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Apr 11, 2024 - 06:32 UTC
Investigating
We are currently investigating an issue with Nordea Open Banking that started at 7:48 CEST.
Posted Apr 11, 2024 - 06:20 UTC
This incident affected: Nordea.