Nordea Open Banking - Major outage affecting Payment Initiation
Incident Report for Tink providers Norway
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Mar 14, 2024 - 06:39 UTC
Identified
We have identified the issue and are in contact with Nordea Bank for further information.
We will update when a significant change to the situation occurs.
Posted Mar 13, 2024 - 17:44 UTC
This incident affected: Nordea.